NOUVEAUTES

OrCAD Vi17.2 - 2016

La miniaturisation et les fonctionnalités accrues
continueront a accroitre la demande de dispositifs toujours
plus petits. Les nouvelles fonctionnalités d'OrCAD Vi17.2 -
2016 répondent a ces défis, d'une part par la mise en ceuvre
de technologies encore plus créatives capables de répondre
aux exigences les plus pointues pour la conception de
circuits Flex et Flex-rigides, et d'autre part par, par I'ajout
de nouvelles technologies aux outils de simulation et
d'analyse de signaux mixtes complexes spécifiques aux
dispositifs mobiles et portables (loT).



Les compléments OrCAD

ORCAD Component Information Portal

Le compagnon idéal d'OrCAD CIS. Depuis les parametres propres aux composants en passant par
I'état de conformité RoHS, la mise en relation avec les distributeurs offre la possibilité d'accéder
aux informations sur des millions de composants commercialisés par des centaines de fabricants.

OrCAD Library Builder

OrCAD Library Builder permet, a partir de datasheets au format PDF, la création automatique et
instantanée de symboles de saisie de schémas et d'empreintes PCB conformes au standard IPC-
7351. Une liste exhaustive de boitiers est disponible, parmi lesquels BGA, CHIP, CHIPARRAY, DIP,
LCC, LGA, PLCC, QFN, QFP, SOJ et SOP

OrCAD PCB Productivity Toolbox

Véritable boite a outils dédiée aux PCB, OrCAD PCB Productivity Toolbox a pour but de rationaliser
les taches les plus fastidieuses et améliorer ainsi la conception des PCB les plus complexes.
Parfaitement intégré au menu d'OrCAD PCB Editor, OrCAD PCB Productivity Toolbox n'impacte
aucunement les habitudes des concepteurs, tout en offrant une palette d'utilitaires appréciables et
puissants.

OrCAD Panel Editor

OrCAD Pannel Editor est I'outil idéal pour optimiser la mise en flan de circuits imprimés, il permet
de panéliser automatiquement les circuits, de rajouter des coupons de tests, des mires de centrage,
des trous de positionnement et des commentaires.

OrCAD Documentation Editor

La documentation des PCB est un élément essentiel de la chaine de conception, dans la mesure ou
elle définit les spécifications relatives au mode de fabrication d'un produit électronique. OrCAD
Documentation Editor résout les problemes spécifiques a la documentation des PCB en supprimant
les obstacles et en rationalisant le cycle documentaire.

OrCAD Engineering Data Management

OrCAD Engineering Data Management est un outil de gestion de projet collaboratif
particulierement efficace, il fournit un environnement de collaboration et de gestion compléete pour
les utilisateurs OrCAD Capture. Des rapports automatiques permettront au responsable d'équipe
de suivre au jour le jour I'avancement des projets, la charge des équipes, les temps consommés,
administrer et attribuer des pages de schémas a son équipe d'ingénierie a travers un seul et unique
emplacement centralisé, et enfin de contrdler les droits d'acces pour chaque partie du projet



NOUVEAUTES

OrCAD Capture V17.2 - 2016

Artedas France vous présente les nouveautés d'OrCAD
Capture V17.2-2016

Nouveautés OrCAD Capture V17.2 - 2016

® visualisation de différences entre schémas.
® Annotation avancée.

® Réglages étendus des Preferences.

® Browser des schémas de démonstration.

® XML, PDF et ISCF.

® Import : Altium Designer et CadSoft Eagle.



® Visualisation des différences entre schemas :

Le menu Tools=>Compare Designs vous permettra d'analyser les différences entre deux schémas,

dossiers schémas et pages.
[
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® Annotation avancee:

Avec ce nouvel outil il est possible d'annoter un schéma avec des rangs de numérotation différents
par page, par dossier schéma ou alors annoter globalement mais aussi en fonction d'une propriété.

Par dossier schéma,
page, design...

’l

Par propriété ..

® Réglages étendus des Preferences:

Les options TCL ont été placées dans les

Options
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® Schéemas de demonstration:

En utilisant le menu File>Open->Demo designs, une fenétre contenant tous les projets de
démonstration en fonction des produits pourront étre ouverts et utilisés simplement.

I

0
0

W M M M W

h 4 N N N Y
8-bit BCD counter using Xilinx devices Y N N S N Y
8-bit Digital to Analog converter Y N Y N Y
80C51 Board Schematic Y N N N Y
AC Analysis of RC circuit Y N Y N Y
ADC parameterizing circuit Y N Y N Y

'l g 'l g ] =

[ Open I cancer |

® Importation/exportation de données

m PDF Export:

Les convertisseurs Postscript=>PDF comme Ghostscript® ou Adobe Acrobat Distiller® installés, la
création d'un PDF a partir du menu File>Export vous permettra d'exporter un fichier PDF contenant

votre schéma et/ou un PDF des propriétés avec un cross probing entre les deux.

Le PDF exporté affiche :

» La hiérarchie du schéma avec descente dans les blocs
» Des listes des références, des broches et des nets
» Les propriétés des objets par simple clic.
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Export :

Cet export contiendra les propriétés des parts, pin et nets de type ground au format Intel
Schematic Export Format.

Il est possible d'éditer les listes des propriétés a exporter qui seront conservées dans le fichier
Capture.ini:

ISCFPartProps=value,ID,Mame,PCE Footprint,Part MNumber
ISCFPinProps=nNumber ,Name,Type
ISCFGroundhames=GHND,GND_EARTH, O, 0

m Export/Import XML :
Les fichiers de bibliotheques et schémas peuvent étre exportés/importés en utilisant le menu
File=>Export—>Design\Library XML et File=>Import->Design\Library XML.
Un script TCL peut étre écrit pendant le processus d'import des .olb et .dsn,.

1 B XML To DSH ==
7 DSN To XML == -
— HML File didesign_testinginew_projxml | |
DSM File dicadencelsph_17.Ztools\capturelsamplesipeh-laya | | .. | —
— DS File didesign_testingtestinew_proj.dsn | |
HML File dicadencelsph_17 2toalsicapturelsamplesipeb-layo | | -
— Overwrite Mode Dont averwrite, generate new design name
Log File . dicadencelsph_17. 2Moolsicapturelsamplesipeb-layo | | . . 8 —
— Log File A |didesign_testingitestinew_praj.log | |
Yiew Qutput ¥ - - —
— Generate Tt . |ddesign_testingite stinew_proj.tcl | |
#ML Schema yitoolsicapturetclscriptsicapdmdsn xsd | Wiew | —
R #ML Schema ¥ T 201 ¥-2-0ools\captureitclscriptsicapdbidsn.xsd | Wiey |
Ok || Cancel || Help |
0K || Cancel || Help |
]
x| ' B XMLTo OLB =
OLB To XML =]
OLB File dicadencelsph_17.2oolsicapturelsamplesipeb-layo | - | HML File ditestamplifierm ‘_|
HML File dicadencerspb_17. 2Mools\capturelsamplesipoh-layo | . | OLBFile ditestiamplifier.olb ‘_|
. — Overwrite Mode Don't overwrite; generate new library name
Log File .4 |dicadencelsph_1 7. 2tools\capturslzamplesipeb-layo | . | o
) T Log File . diestiamplifierlog ‘ |
Wiew Dutput ¥ —
. " G te Tcl dite sty lifier.tcl
ML Schema yiitoolsicaptureitclscriptsicapdbiolh xsd | Wiew | Enerale T = Estampler tc ‘_|
XML Schema dicadencelisph_17.2t00ls\capturettclscripts\capdhi ‘ Wiewy |
ok || cancel || Hem |
OK || Cancel || Help |
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® Import de schémas:

m Altium Designer:
Le menu File>Import-> Altium Schematic Translator vous permettra d'importer un schéma
Altium sauvé au format Ascii .schDoc.

Le schéma Altium doit étre embarqué dans projet PCB (.prjPCB) qui gere les données du projet pour
la fabrication.

m CadSoft Eagle:
La version contemporaine d'Eagle sauve le schéma au format XML, le fichier .sch suffira donc a
I'import dans Capture.
La passerelle sera intégrée dans un QIR-17.2 a venir
En attendant, Artedas a le plaisir de vous offrir cette passerelle qui s'installe sur les versions 16.6 et
17.2. Aprés installation, la commande est disponible dans le menu File=>Import->Eagle Schematic
Translator.

Import Eagle Schematic Build 61 % |

Eagle .schfile |

OICAD output path |

Leave this field blank ifthe output files are located in the same directory as the source {sch) file
v Cleanup intermediate files

Translate | Cancel | [} Help |

Nouveautés OrCAD Capture V17.2 - 2016 Artedas France



m Eagle:
Il est désormais possible d'importer une carte ou une bibliothéque d'empreintes Eagle avec le menu:
* Pour Allegro PCB Editor:
File=>Import->CAD Translator->Eagle PCB or Library.

= Pour OrCAD PCB Editor:
Import->Translators-> Eagle PCB or Library.

ﬁ' anl{e PCB and Library Translator - O
Ly
el o fle: | -]
Prezz Tranglate and select Eagle board/library file to be translated!
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NOUVEAUTES

OrCAD & Allegro PCB Editor
V17.2 - 2016

Artedas France présente les nouveautés

de PCB Editor V16.6.

vous

Nouveautés PCB Editor V17.2 - 2016

® 64 bits.

® pad Designer.

® Cross section.

® Conception Flex-Rigid.

® |nterface graphique.

® BackDrill.

® Contour de carte.

® Constraint Manager.

® Détection d'angles (DFM).

® Fonctionnalités d'Allegro descendues dans OrCAD Pro.

® Import Altium, Eagle.
o ..

Les nouveautés des produits sont aussi accessibles par
l'intermédiaire du menu Help>What's New.



® Base de données et systeme d'exploitation :

m Labase de données de PCB Editor est écrite en 64 bits.

m Les systemes d'exploitation supportés sont:

= Windows 7,8,10.
= Linux RHEL 5.10,6.5,7.1, SUSE11 (SP2,SP3).

® OrCAD PCB et Allegro PCB Editor :

m Pad Designer
= Nouvelle interface graphique:
L'interface a été complétement revue et est présentée avec des onglets contenant les
fonctionnalités des pads. Celles-ci dépendent du type de pad, si une pastille SMD est en cours de
réalisation 'onglet Secondary Drill est inaccessible. De méme lorsqu'un Fiducial est en cours de

création, les onglets de drill sont désactivés.

A Pad Editor: 55r36 (C:/Cadence/SPB_17.2/share/pch/pcb_lib/symbals) = &
File View Help cadence
e d
2D Top Padstack Yiew 5 X - . . . N .
Skart | Dorill | Secondary Drill | Drill Symbol Drill OFFset I Design Lavers Mask Layers Options Summary

Select padstack usage:

F-—1LFxT%4; =

Thru Pin SMD Pin Via BEVia Micravia Slot
oo /j -~
Mechanical Toaling Maunting Ficducial Band Die Pad
Hole Hole Hale Finger
w

Select the default pad geometry:

2D Padstack Side Views g X

Oblang Rectangle Rounded Chamfered
Rectangle Rectangle

Circle Square
Octagon Donut n-Sided
Palygan
w

Side Front

Thru Pin | Units: Decimal places: m ‘

= Nouvelles géométries :
Ces exemples n'illustrent qu'une partie des possibilités. Ces nouvelles figures sont supportées par

['IPC2581.

» Rounded Rectangle avec rayon et coins paramétrables. - -

Nouveautés PCB Editor V17.2 - 2016 Artedas France



» Chamfered Rectangle avec chanfrein et coins paramétrables. ' '

» Donut

» n-Sided Polygon avec nombre de faces paramétrables. . .

=  Nouveaux principes de percage :

» Le Square Hole Type est supporté pour les usinages a l'emporte-piece
ou les microvias.
» Le Drill Tool Size définit la taille de |'outil il too| size: 45 Gas
avant métallisation, la valeur entrée n'est
ALL UNITS ARE

pas influencée par 'unité de conception et est INISHED S1ZF TOOL SIZ
seulement reportée dans le tableau de pergage. De _
plus ce champ est parfaitement libre.

» Lechamp Finished Diameter/Finish Size |Fjriched diarmetar: 2800

remplace le Drill Size utilisé dans les
versions précédentes et est exploité dans le fichier de percage.
» Le Slot Tolerance peut étre définiten X et .
Le Secondary Drill est apporté aux pads qui
. o
embarquent maintenant les champs de _L
diametre et symbole de percage du BackDrill

| \ | mh
mais aussi deux nouvelles définitions d'usinage - " —

comme Counter Bore et Counter Sink. \< >/
k- Dia -ﬁ F—Bﬂl’* rill Dlnmeter—..l

[
= Nouvelles régles des pastilles : ﬂ 3

» Shape multiple sur géométries des couches de

masques, ce masque doit étre créé en mode flash (.fsm)

Select pad to change

Layer Mame Regular Pad Thermal Pad Anti Pad Keep Out
BEGIN LAYER Circle 52 Circle 66 Circle 66 Circle 60

» Options Lock layer span pour les BBvias et Suppress Unconnected internal pad; legacy

» Notion de Keepout embarquée

dans la pastille.

artwork toujours pour supprimer les pastilles dynamiquement voire a la création des gerbers.
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m Cross Section
La fenétre de Cross Section a

, L, f Physical == Physical <<
Compl'etement ete revue a In_de LayeriD|  Material LaveriD| Material | 'sgmore | HoFillet ls':::ﬁ':::;:) g:ﬂ;’;’::;::)
pouvoir supporter la conception : : : : - - :
de Flex et certains attributs qui

. Soldermask Soldermask
rendent la construction et [i Copper 1 Copper O
re . Fr-4 Fr-4
l'ut|l|sat|0n beaucoup plus 2 Copper 2 Copper 1 1 ]
s e ff Polyimide R... Polyimide R...
précise et efficace. - Copper q Copper =) O =)
4 Polyimide Fi... Polyimide Fi...
Chacune des colonnes présentes —— Corper - » =
dans un Stackup est affichée en Polyimide R... Polyimide R...
; , 5 Copper 5 Copper 1 1 1
compressé par défaut et peut Fid Fi-a
~ , , . 5] Copper 5] Copper |:|
étre développée par simple Soldermask Soldermask
double-clic ou clic-

droit-> Show More.

Le Cross Section possede maintenant des menus qui permettent d'importer et exporter des

stackups au format IP2581 (.xml) et fichiers technologiques

(.tcfx) mais aussi d'éditer l'ordre des

stackups et des masques mais encore un fichier Site contenant les matériaux Flex.

5 onglets dans le bas de la fenétre permettent de contréler:

Info Lock | Embedded Lapers Setup
Total thimless: 48,2 mil
Total thickness without masks: 36,2 mil
Lavers: 14
Conduckor: 6
Flane: ]
» Info: lesinformations générales de l'empilage. Masks 8
Infa | Lock | Embedded
. T [Lock
» Lock: bloquerl'ajout de couches et/ou 'édition de valeurs. [ add Layers
[ walues change
> Embedded Layer Setu p (Allegro Infa | Lock | Embedded Layers Setup | Unused Pads Suppression | Refresh Materialz
1. Package height buffer (4323 (6]
option Miniaturization) : Pour le | 2 Minimum cavity gap for merging s
; 3. Placebound o via keepout expansion (1)
pa ra metra ge des com posa ntS 4. Package to cavity spacing
, 5. ¥ia connect height ts
e nte rres. 6, Default via connect padstack
7. Cavity to route keepout expansion
» Unused Pad Suppression : Activation de la Info | Lock | Embedded Lapers Setup | Unused Pads Suppression
suppression dynamique des vias et pads et affi (] Dynamic urused pads suppressior
, [pisplay padless holes
chage des percgages résultants.
. nfo | Lock | Embedded Layers Setup | Urused Pads Suppression | Riefresh Material:
» Refresh Materials : Permet de rappeler les

valeurs sélectionnées des matériaux et attributs
contenus dans le fichier de matériels.
(matérials.dat)

Nouveautés PCB Editor V17.2 - 2016

[ all values

[T Electrical Conductivity
[ piglectric Constant
|:| Loss Tangent
[Imaterial Thickness

[C]Frequency Dependent File Refresh Materials
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® Cross Section Editor (Multi Stackups mode) - b
Export Import Edit View Filters
#llstackups | Primary | Flext | Fles2 | Fiewd | + | CIERICN |
o Types >> Thickness »> Physical >> Embedded > Signal Integrity > ~
) Value - Conductivity | Dielectric
Layer Layer Function Layer ID Waterial Status Sl ignore
a Hame L | = mil = mho/em Constant = Surface
I " 5 5 5 SOLDERMASE TOF Mask
Surface 1 _ 1 TOP Conductor
SOLDERMASK_TOP Mask Solder Mask 2 0 3T ] P —
1 [[ToP Conductor || Conductor 12 1 Copper ot 595900 45
Al falele £ = 2 INT I Conductor
5 Frd 0 45 O =
2 Jr_i Conductor _[| Conductor 12 2 Copper ot 595000 45
\Dielectric || Dietectric 5 Polyimide Rigid 5mil 0 3.5 OJ
3 [|FLEX_1 Conducter _[| Conductor 1.2 3 Copper Not 595900 45
Dielectric Dielectric 5 Polyimide Film o 35 O
4 [|FLEX 2 Conducter _[| Conductor 1.2 4 Copper Not 595900 45 O
Dielectric Dielectric 5 lyimide Rigid 5mil o 35 O
5 [mT_4 Conducter _[| Conductor 1.2 s Copper lot 595900 45 |
Dielectric Dielectric B Frd o 15
6 | [soTTOM Conducter _[| Conductor 1.2 6 Copper lot 595900 a5 0
[SOLDERMASK_BOTTOM Mask || Solder Mask B o 37
surface 1
v
4+ \Properties [ | < 2
Info | Lock | Unused Pads Suppression | Rehesh Materal:
Takal thickness: 40,2 il
Tokal thickness without masks:  36.2 mil L
Layers: 8
Conductor: &
Flane: 0
WMask: 2
Ok, Cancel Apply Help

t | View | Filters

v | le Stackups mode

m Flex Design (OrCAD Pro et Allegro):
Lors de la premiere ouverture du Cross Section, seul un onglet <hom All Comne
Primary apparait, il suffira d'activer le Multi-Stackup Mode a Al stackups | Frinary | + |
l'aide du menu View.

Apparaitront alors l'onglet Primary et + ainsi qu'une colonne

Lays
Add Stackup. - # - Hame ! L

T
Objects L

Les stackups des flexs et cartes seront ajoutées a l'aide de Surface
l'onglet + ou la colonne Add Stackup. 1| Top Conduc

Puis les couches constituant les différents empilages seront ajoutées dans 'onglet All Stackup
seront activées dans les stackups pour lesquels elles seront destinées.

&= Cross Section Editor (Mult Stack:
Export Import Edit View Filters
All slackupsl Prirnany ] Flex1 l Flex2 l Flex3 l +I
. Types .
CDIELE e Material Primary | Flext Flex? Flex?
Layer -
b Hame mil
(D T O 0 0 O T T
Surface ] /] [v] [+]
STIFFEHER_TOP Mask H Fr-4 [] [] v] []
COVERLAY_TOP Mask 2 Polyimide Film 1mil [ ] ] 7
ADHESIVE_TOP Mask 0.5 Adhesive Acrylic ] V] [v] [v]
SOLDERMASK_TOP Mask 2 Soldermask ] [] [ ] []
1 ||ToP Conductor  [1.2 Copper ] ] [] ]
Dielectric [ Fr-4 ] [] [ ] []
2 BNt 1 Conductor  [1.2 Copper ] ] [] ]
Dielectric 5 Polyimide Rigid 5mil ] [] [ ] []
3 | |FLEX_1 Conductor  [1.2 Copper ] V] [v] [v]
Dielectric 3 Polyimide Film ] /] ] [+]
4 | [FLEX_2 Conductor  [1.2 Copper ] V] [v] [v]
Dielectric 5 Polyimide Rigid 5mil ] [] [ ] []
5| (InT_4 Conductor  [1.2 Copper ] ] [] ]
Dielectric [ Fr-4 ] [] [ ] []
5 | (BOTTOM Conductor  [1.2 Copper ] ] [] ]
SOLDERMASK_BOTTOM Mask 2 Soldermask ] ] v| [+]
ADHESIVE_BOTTOM Mask 0.5 Adhesive Acrylic ] V] V] [v]
COVERLAY _BOTTOM Mask 2 Polyimide Film 1mil [] ] v| [+]
GOLD_SOFT_BOTTOM Mask 1 Gold ] ] ] [v]
Surface v of! o o
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Les nouvelles class Rigid Flex et Surface Class:Rigid-Flex Class: Surface Finishes

ni H . Bend_Area — Carbon_Bottom
finishes comportent les layers suivantes : " berd Line T Carbon Top

— Enepig_Bottom
— Enepig_Top

— Coverlay_Bottom
— Coverlay_Top

—  Emi_Shield_Bottom ~  Enig_Bottom
—  Emi_Shield_Top ~ Enia_Top
—  Stiffener_Metal_Bottom - go:gf:ar;i*?mwm
- Stiffener_Metal_Top - Ggldisgfrt Bo(:::)m
—  Stiffener_Bottom _ GoldisoﬂiTop
-  Stiffener_Top —  Immersion_Silver_Bottom
— Transition_Zone - Immersion_Silver_Top
— Zone_Outline — Osp_Bottom
- Osp_Top
—  Silver_Ink_Bottom
— Silver_Ink_Top
— Tin_Plate_Bottom
— Tin_Plate_Top

= Gestion des zones des stackups: (OrCAD Pro et Allegro):

Les particularités des flex et rigides

amenent 'obligation d'affecter un stackup Options =
a une zone pour pouvoir gérer les
err s . Zone Dat
différences d'empilages et les zones de e
.. Mame ZOME_2 -~
transition entre stackups. Stackup PRMARY |~
Constraint reg
R oom
W

Zone Manager...

Zone Creation Controls

Line lock: Line g0

= |ntermediate Layer Check (OrCAD Pro et Allegro)
Cette fonctionnalité permet de vérifier les géométries entre deux Class/SubClass différentes. En
effet, ['utilisation de flex combinée avec une partie rigide impose des zones de pliage, raidisseurs
et autres qui demandent des isolations ou recouvrements de matériels etc.... Tous ces types
d'objets représentés sur des couches différentes imposent des vérifications entre ces couches que

! b £l |
l on trouvera dans le | Spacing Constraint Set
H . B Al Layers
Constraint Manager: Net N
B Al Layers s £
1 Net Class-Class = ,5 E N E E| o £
B Al Layers v s = = E E 3 8 5 0 2 & .
& Csetassignment matrix = g 25 2% 3 :I :\ :\ 2! e A
 Region = ElEW Y33 WERTRRD LS
1B All Layers = 2 5 = 5 & ¥ oz og @ EEE & i e
Inter Layer 208D EEEESSEELE T
- o = ~HME £ E 5 S| 5 S 90 ©l e oo =| &«
@Spacing M2 3 F F R @& & &5 @A ;A oA A wmoa o
Adhesive_Bottom ooooooooooDoooo.o.o |
Adhesive_Top o o o o
Assembly_Flex_1 OgoooooooooEm|onod o
Assembly_Flex_2 Ooooooooooooooon 0oa
Bend_Area [mp{mpi] ooooooDooooo 0og
Bend_Line Oo|a|a L T T o
Carbon_Bottom 0|00 |0 i Delete rule between, B.indé'ei.‘mi.-ﬁ'ﬂm.iﬂ‘i!] o
oA Ay, W, Lo R e LA e R e O e s R T e A e N s O e A e |
<
Layer 1 Layer 2 Type Vaue Enabled DRC label DRC subclass
Bend_Area Transition_Zone Overlap |15.000 s} SOLDERMASK TOP
Caoverlay_Flex_2  Gold_Mask_Bottom |2 inside 1/ 10.000 O G SOLDERMASK_BOTTOM
Same Net Spacing Soft_Gold_Flex_1 Coverlay_Flex_1 1inside 2|0.000 |[] M SOLDERMASK_TOP
Properties Bend_Area Stiffener_Flex_1 Gap 20.000 [ S SOLDERMASK TOP
<
DRC

1 Ti Z Tele
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= Tableau Multiple Stackup
La conception de cartes multi-stackup apportant des niveaux de couches hétérogenes, le Cross
Section Chart a évolué en ce sens et permet de créer une table reprenant les empilages par zone.

5¥ Cross Section C4... — [ -

Char: | Table |
Table titks: [MULTIPLE STACKUP TABLE
Tent block name: v

Tent block: 1 =
Height expansion; |0.00 %

Table notes:

Table Column Options

Layer number

Layer name

Layer lype

Layer material name
Thickness tolerance

Zohe hamg

ak. Cancel Help

m Controles de couleur et visibilité.

La fenétre Color192 et Visiblity adoptent une nouvelle vistilty | _
, . . ., Wisibility - x
présentation et apporte de nouvelles fonctionnalités telles qu'un
filtre, les favoris ou le découpage des principales fonctionnalités Global visiaility | On off Last
dans leur propre onglet. De plus, il est désormais possible de Ve _
. ' . Layer Stackup | PRIMARY -
glisser les class/Subclasses que |'on souhaite dans le panneau de
controle Visibility. [¥] Pianes ooooog-
Masks o0oodod
All Layers D D D D D D
¥ Color Dialog Tin_Plate_Tap
Pasternask_Top |:| |:| |:| D
Layers | Mets | Display | Favorites | Wishility Pane Soldermask_Top () (o []
Top (]
Filter layers: |sik nt_1 (]
Flex_1 E |:| |:| |:| |:| D
» Stack-Up PkgGeo Flex_2 CRCRCICRC N
> Areas All ¥ Int_4 [
4 Geometry Silkscreen_Bottom I:I EEIEm ogom
Board geometry Pastemask_Botom N W []
Package geome... et Solder mask_Bottom L 1R R
Embedded geo... e Through Al [ ] W]
Add to favorites Class/Subclass (user selected
. - [
Add to VI5I|)I|IL\\§ 0
» Panneau Visibility: o
[ ] Enable layer select m&de
La visibilité globale peut étre affectée directement dans le visibility -8 x
panneau Visiblity avec les boutons On/Off/Last.
Global visibility Oon Off Last
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Les niveaux de masques peuvent

étre ajoutés/retirés du panneau
Visibility.

Llwer

Blan Etch Yia RPin Drc All

Conductors
Planes

All Layers

Tin_Plate_Top
Pastemask_Top
Soldermask_Top

= Personnalisations des Stackups:

Layer

Plan Etch Via Pin Drc All

[#] Condurtors [ vl ¥ ¥ [
%] Planes O OO0
C ek Ooooog
all Layers [] ] v [v] []
= mEEEEQ
Int_1 (] ] () ]
Clewe 1 - ] - .

Dans le cas de Stackups multiple, il est possible de personnaliser les class/sublasses a afficher

dans le panneau Visiblity.

Color Dialog

Layer Stackups

##
Layers MNets Displary Favorites Visihility Pane
Visible classes
Plan Etch Via Pin Drc
-l

Available classes

Pastem ask_F
Gold_SoftFI
Flex_1

<

AntEtch Bound BrdGeo Cavity CnsRgn Drawing Pkg KI Pkg KO PkgC

Flex_2

>

[FLEX2
PRIMARY

Adhesive_Flex_2

Coverlay_Flex_2

Visibility -8 %
Global visihility on Off Last
Wigw -

Layel

Clayer stackup FLEX2 D -
PRIVERY
FLEX-1 |
.
Conductors | [ Ex-3

Planes EIEE:E‘;
Masks
All Layers |:| D

Coverlay_Flex_1
Adhesive_Flex_1
Pastemask_Flex_1
Gold_Soft_Flex_1

Flex_1 - (] ] ] (]
Flex_2 | Active Command 1
sdhesive_F[ | App Status
Corverlay_Fl T Extra 1
g A E Active Class/Subclass ]
4 Mouse XY Coord
= Personnalisation de la barre de commandes: | Pick Command
R . . R . . o 4 Toggle XY: Absolute/Relative
Un simple clic-droit fait apparaitre la liste des éléments de la barre, v| AuwysciptText
il suffit de désélectionner L e Mode
v | App Mode
l'élément. . e [|unnan s i Super Filter |
+ | DRC Status |
Idle - Tap -45,000, 2010.000 Flla [¥] selected Objects ar:
m Constraint Manager
= Nouvelle classification d'objets:
Un nouveau Type nommé OTyp CEREE | [Type || Name : I
A L, -0 Spacing Constraint Set
(ObJeCt Type) est utilisé dans le LB AN Layers Dan, [ Module10_ZonePLaceme [DEFAULT b
. Ty El  MNet Classes
CM pour classer les objets %e;m == CLS A W) DEFAULT -
e (2 E NCls CLS_B {4) DEFAULT =
comme les Class, Net/xnets’ —-0 Net Class-Class OTyp B Diff Pairs
paires différentielles. B All Layers DPr DP1 DEFAULT -
& CSetassignment matrix G op2 DEFAULT
. Ty E XMNets/Nets
-3 Region i d n1 DEFALILT e
= Affichage et réglages par couches: Objects
Le type LTyp est utilisé maintenant dans le Constraint Manager : e S e
Dsn 2 MWodule10_ZonePLaceme
SCS B DEFAULT
LTyp B Conductor
Lyr 1 TOP
Lyr 2 INT_1
Les colonnes d'objets ont été compressées par défaut et peuvent étre i o
développées par double clic afin de rendre la lecture des valeurs plus Bz sorrom
pratique.
,&-\Line e P:I]I g PA"III S P:;;ITo " All 7/ Line Thru Pin [ SMD Pin | Test Fm‘p
[ mil mil mil mil mil mil mil mil mil mil
e B - o ﬁ\\ﬂ 0 O o r
5,000 5000 8.000 8.000 8.00C & 000 000 000 000 B nnmgd-s—ngm—/ &0
5.000 5.000 8.000 3.000 3.00C 8.000 5000 5000 5000 5000 5000 B0
5000 5000 G000 8000 500 5.000 8.000 8.000 3.000 3.000 3.000 3.0
5.000 5000 £.000 8.000 8.0 B.000 BO00  [s000  [a000  [RO00  |ROo0 &d
2000 5000 8.000 3.000 3.00C 5.000 5.000 5.000 5.000 5.000 5.000 50
8,000 8.000 6.000 9.000 5.00C 5.000 5.000 5.000 5.000 5.000 5.000 50
8000 8000 £.000 &.000 8.00C B.000 BO00 @000 @000 @O0 |aoo0  &d
B.000 A.000 B.000 B.000 i 00 £.000 BO00  s000  [a000  [RO00  |Roo0 &d
5.000 5.000 §.000 3.000 5.00C 8.000 5.000 5.000 5.000 5.000 5.000 50
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=  Matrice Class-Class:

Le systeme de class a class a été revu pour proposer maintenant une matrice dans laquelle les

associations entre class seront plus simples et logiques a mettre en ceuvre.

forksheet Selector g X

Riowy filter: Colurnn filter !
Electrical
Physical | | ‘
Spacing | | class Nafne Sync Bus_vd Bus_A Blindage Alims
£ Spacing Constraint Set Alims Is0_0.26Mm | ls0_0.26Mm
-8 Al Layers Blindage
d_ Net Bus_A Iso_0.26Mm
~IB All Layers Bus_Vd
3 Net Class-Class Sync
B Al Layers
~I& CSetassignment matrix

m Mode Shape Edit

Ce mode d'application permet de fagon efficace |'édition de contour de shapes.

L'ensemble des commandes du menu Shape ont été intégrées dans le menu
contextuel.
= (Clic-droit en mode Shape Edit :

Au-dessus d'unvoid ...

- — 1
(e Uahies ' Trim corners

Au-dessus d'un espace vide... Slide segment Move
Add notch Copy

Quick Utlities v Undo Move segment(s) Delete

Design Param eters... Rem ove/Extend segm ent(s) Property edit
AddPalygon e Show element show element
Acld Rectangle Change active subclass  *
. R Parameters...

Add Circle Global Shape Param eters Void 4

Delete Islands Shape 4

Application Mode * Application Mode 4

PPl Nouvelles ppice

Super filter 4 —_————— P Super filter 4

Customize 4 commandes \‘> Customize ’

Selection set 4 ajoutees Selection set v

= Cross Hatch Dynamique
Auparavant, seul le remplissage Solid permettait une mise a jour en temps
reél.
Le Cross Hatch Dynamic a été ajouté a la liste des types de remplissage.

Quick Utlities
Expand;/Contract
Trim corners
Move

Copy

Copy to Layers...
Delete

Spin

Add to group
Fix

Property edit
Show element

Add void

Shape Operations

Merge Shapes
Check

Raise Shape Priority
Lower Shape Priority

Update Shape

Parameters...
Report..

Application Mode

Change Shape Type to Static

»

»
Super filter »
Customize L4
Selection set o
Visihility Options

Cptions

Active Class and Subclass:

Etch W

. Bottom '
Shape Fill

Type: | Dynamic copper v

D DEE Cavity

Static crosshatch
@ Unfilled
Shepe 1

Z¥ Property Dyn_The...

(m ) Edit Property - B

= Propriétés par

Available Properties Delete Property Value

Subclass Yalue

Caln_All Py
Celn_Duter

couches

Comment A ] oyn_Thermal_Con_Type
. Dyn_Clearance_Oversize_firay
Influencer la construction Con Clomance Tope
. . ko L et
de freins thermiques par || [oromiemsicom:

Caln_Inner_Plane
Caln_Inner_Signal
Top Oithogonal
In2

In3 Diagonal
Ind

Dyn_Owersize_Therm_‘width_amay
Dyn_Thermal Best Fit

couche pourra étre fait sur O Theral Con oo

Ecset_Mapping_Tag

les pads a l'édition de i

Etch_Tur_Under_Pad ¥

propriétés ou dans le E B

Constraint Manager. "

[ ok || caneel | | Help | | Resst || bppb || Showo

Bolg  |Ful contact | -
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m Contour de carte : Design Outline et Cutout
La classe Board Geometry est complétée par deux nouvelles couches : DESIGN_OUTLINE et
CUTOUT. La couche OUTLINE sera toujours utilisée pour définir un contour fermé sans
particularités.
Elles aménent des controles plus évolués sur:
= QObjets a bord de carte et construction:
-Pad a bord de carte.
-Mask a Cutout ou bord de carte.
-Cutout a bord de carte.
-Réglages des bords des zones de flex par rapport au Design_outline.
= Collaboration MCAD/ECAD:
-Gestion indépendante des Outlines et Cutouts.
-Export amélioré des Steps de Cutout et Outline.

m Arc Routing (OrCAD Std et Pro, Allegro)
Le routage utilise maintenant le DRC sur les Arcs et est en mesure d'étirer ou pousser un arc:

m DRCs:
= Détection d'angles aigus :
Quatre vérifications d'angles sont possibles, dans les shapes de cuivres, entre pistes et

pads/shapes/pistes
Analysis Modes
B Diesign Options Design Modes [Acute Angle Detection]
B Design Modes
P Design Options (Soldermask) DRC modes On  Off  Batch -
P Design Modes [Soldermask) - i = — Analysis Modes x
B Design Options [Acute Angle Detectic Rlioitshsneleaoalioledotonale y
[res ig [s q Clicy Minimurn Line to Pad angle: Design Options [Acute Angle Detection]
P Design Modes [Package) - . = — —~
X . Minimumn Line to Shape angle: L) ] L L
D Electical Options Minirum Shape edge to edge a0
P Electrical Modes Mirimum Line to Line angle: O O O
b Phusical Modes & ErLte Anole De tinimum Line to Pad angle : 90
B Design Modes [Acute Angle Detectio
P Design Modes [Package) Minirnum Line to Shape angle: 90
B Electical Options
B Electical Modes Minirmum Line to Line angle: a0
B FPhysical Modes
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= Détection du trou de la pastille. Analysis Modes |\

Ce nouveau DRC permet de vérifier
['espacement entre trous, que la pastille soit

ou non présente.

Design Modes
Design Optians [Soldermask] Drrill Hole Constraints
Design Modes [Soldermask] Check holes within pads
Design Options [Acute Angle Detecl!
Design Modes [Acute Angle Detect
Design Modesz [Package)
Electrical Optians

Electical Modes

Physical Modes

Spacing Dptions

Spacing Modes

DRC emor "Dril Hole to Dril Hole Spacing” Top
Constraint value: 2 MM
A JActual value: 0828 kb

v A A

= Détection de texte a 'extérieur de la carte.

Enimplantant la propriété

NODRC_ETCH_OUTSIDE_KEEPIN sur le texte posé sur R E L E A S E 1 7 . 2

une couche Etch a l'extérieur
du Route Keepin, il n'y aura
plus de DRC détecté.

Nouveautés PCB Editor V17.2 - 2016
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. Metal Usage R. = =
m Outil Metal Usage Report (OrCAD Pro et Allegro) C Ll
Utilitaire permettant de calculer la surface de cuivre utilisée par couche Fieene.  [ntalusoge vt
sur ma carte ou une zone délimitée par un shape, un symbole ou une o
fenétre. O Select symbol
() Select shape
Metal Usage Report
[JInclude ratio table for selected layers
QX E =] ?. Search: [ Match word [ ] Match case B |t Layers> A
® |SOLDERMASK_TOP ls
Design Name: finished3dl7z [T
Report Generated: May 02 13:42:15 2016 B |IN1
B |PLAN_GND
Search Region: Lower Left: (-10.0426 16.3514) Bl |PLAN_ALIMS
Upper Right: (-4.7142 11.1783) B |IN2
® [BOTTOM
® |SOLDERMASK_BOTTOM
Layer Totzl Area Metal Area Metal v
(aq cm) {3g cm) El < >
= = . = wiite report ‘iew repart
o ASK_TO! 2% . 84.69
or o e 2ioeen 1273 | Aot bl
™ 0.2756 0.0351 12.72
PLAN GND 0.2756 0.2756 100.40

m Outil Shape Degassing.
Cet outil automatise la perforation des shapes de cuivre pour e
éliminer les phénomenes de dégazages lors de la fabrication
de la carte.

¥ DiameterSize
¢ [0.2000 milmet:| : 02000 wilimet:

id separation: [0.1016 millmet| - [01015 milimste

idpich % [0.3016 milmet ;03016 millmete EI
Aray angle: 0.0000 v

[ Rotate veids at array angle [ $tagger pattem

Starting posiion: | Lower Left v
Offset % [0201E millmet| : [0.2016 millmet:

Custom point %:  [0.0000 millmetc Y: [0.0000 milimete

Void Spacing Constraints

Do not degas shape less thar: |[0.6360 milimsters

Voidto

izl [01016 milimeters |
=
m Nouvelles fonctionnalités de l'IDX: 2 IDX In -
La gestion de |'IDX a été largement améliorée par D% File:  [FINISHED 30172_INCREMENTAL_DATA ids
I'ajout de fonctionnalités sur les points suivants : [ Use 25 baselne TV I y
= Réglages du User Preferences, propriétés IDX. MEAD Compare Repart
= Prise en charge du composant (Hauteurs mpar Viewiaq Hel
multiple, pin 1).

= Prise en charges des layers user et des Bogrq ~ DCHEORSEIONS DY Dy

couches cuivre externes. N ‘ ) /N
|

* Prise en charge des trous borgnes (e ipgae vodud | |

Peclzge_height max =100

et rectangulaires. ey e

Daclzge height min=30

Select definitions to up

= Utilitaire de comparaison IDX. T 00E Packess

[ % ENC
IND200
LED_3M_Cé
FLCCZ28
PLCCE4
SMC_B032
Sh_0205
SM_1206
s0Ice
sS0Icz20

m Refresh Symbol : s0iCa2
S0IC48 o

= M a i nti en d unom d e pa Sti “e or enter a file containing a list of spmbols:
|

K.eep design padstack names for symbal ping

CEECL OO

|
|
O
m|
m|
W
-0
-0
|
|
|
M

I
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m Paires Différentielles :
= Paires différentielles dans OrCAD PCB Editor Standard:
Les paires différentielles sont supportées en Electrical et Physical dans OrCAD PCB Editor Standard

etinclut la prise en charge de la Static Phase.

o Allegro Consfraint Manager@AD PCB Designer Standard 17. iif_pair17 2] - [Electrical / Elec
eIp

= File Edit Objects Column View Analyze Audit Window

% 0B - Vilg Qe fle V= % T Laa) & - % - 50| % % 55l

HE
‘Warksheet Seleckor B X diif_pair1 72 ]
[# Electrical | Objects Uncoupled Length Static Phase| Min Line
SR i ? i Max Tolerance Spacing Primary Gap |Prim
Gather Control
(= ]% Routing Type |S Hame mm mm mm mm
: ..[# Differential Pair ' E
E| 0 Net Dsn £ diif_paig172
- JB Routing ECS DIFF1 5 1 mm 01700 0.1800 0.200

* Dynamic Phase Control ( OrCAD Pro et Allegro)
La Dynamic Phase est prise en charge dans OrCAD PCB Editor Pro et Allegro PCB Designer

Ch Allegro Constraint Manager (connected to OrCAD PCB Designer Professional 17.2) [clif_pair172] - [Electrical / Net/ F
= File Edit Objects Column View Analyze
> = i
» 00 % v/ iz Qe [ |G T | D
Waorksheet Selector g X diif_pai SPhass +0.7147
| & Electrical " Static Phase Dynamic Phase
B |_| Electrical Constraint Set
LA Actual Margin e CenmihiRlolerance Actual Margin
@ Routing Type (S mm i
B Wiring . . .
B Impedance Dsn -0.3048..
B Min/Max Propagation Delays [oTvp
B Total Etch Length IDPr = mm 1.0000 0.01 mm -0 3044...
"B Differential Pair [Het X 1 mm 1.0000 0.01 mm
£ Net |net Y 1 mm 1.0000 0.01 mm 20.3048..
E LB . |oPr DIFF3 1 mm 1.0000 0.1 mm
= Routing foTom F Xletstlets I I

= Affichage des drivers:
Quel que soit l'outil utilisé, les drivers de paires pourront étre affichés des

lors que le type des broches utilisé est Output. =i
[] Ditfpair driver pine

[TTze secandary sten madels in 30 viewe

m Pistes adjacentes a un void de plan (OrCAD Pro et Allegro)
= Détection:
La détection de pistes en vis-a-vis d'un vide dans un plan
de cuivre avec la commande Display—>Segment Over
Voids (SOV) mettra en surbrillance permanente les pistes
posant le probleme.

= Modifier automatiquement les SOVs:
Cette commande modifiera automatiquement les pistes
concernées pour les pousser sur une partie couverte par

plan.

Artedas France
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m Line Fattening entre via tangents ( OrCAD Standard et Pro,
Allegro)
Cette commande est accessible par les menus e e
Route->Resize/respace->Via-Via Line Fattening. | vumneuosig [rm

[]'waive Impedance/Max Line Width DRCs

® Entire Design

Selected Clines Only

Run Ling Fattener Eancelll}

Help

m Routage avec Contour (OrCAD PCB Pro et
Allegro)
Lors d'un routage, il sera possible de suivre le
contour de la zone Route keepin ou une piste.
Gr

(®) Route Keepin

Contour

() Connect Line
Extra Gap %5. 0on v

Cancel Help

m Routage en groupe avec controles evolués (Orcad PCB Std et
Pro, Allegro)
La commande Add Connect comporte les options Route

. . . GF Route Spacing =
Spacing et Via pattern qui permettent de router un

. . , Spacing Mode: (®) Current Space
ensemble de pistes simultanément. O Minimum DRC
() User-defined
Space: 0.2100

Cancel Help

m Définition de jeu de couches (OrCAD PCB Pro et Allegro)

Les jeux de couches (Layer TSI B R—
Sets) sont maintenant Optians - 8 x
d ISpOﬂibleS d ans le 1 Electrical i‘i::ﬁij"l Set : Objects “e'e'e““(‘

. ©.[E Routing Type |5 lame v [t
Constraint Manager de & Wiing — v

. B Impedance Dsn B finished3d172 -
OrCAD PCB Designer Pro. Ils b oo Dy N
permettent de définir un 8 ofeemalrer o M s A =
ayer Sets - O

'utiliser sur un net,

Top2GND

Het A2
ensemble de couches pour  © et as ’7

NetClass ect e
e Layer Set name: Ext_TOP
New Delete
Awailable Lavers [¥] tsutto gfove Asadyed Lavers
TOP TOF
1M1 M1
PLAN_GMD
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m Fonctions évoluées de nettoyages (Gloss) (Orcad PCB Pro, e

A[[egro) Application Run
Toutes les fonctions de Glossing (nettoyage) d'Allegro Designer ont Line And viacleanup -
été descendues dans OrCAD PCB Designer Pro , orientant ainsi cet Vi eirinale -
outil de facon certaine vers la fabrication de la carte. Lne smorthing =
Center lines between pads O

Improve line entry into pads |

Line fattening O

Convert comer to are ]

Filet and tapered trace |

Dielectric gereration O

Gloss Cloze Help

m Via Structure:
Cet outil vient compléter l'outil de Fanout par ['utilisation de structures de routage (Vias et Clines).

= Création de Vias Structure standard (OrCAD PCB Std et Pro,

Create »
Allegro): Add...
Menu Route->Via Structure—>Create—> Standard, Replace

o . . . . Repl WVia with Via S
utilisable sur cline unique et Fan-out (cline et vias) s it Via ruceure
ETresn ..

Redefine

Dishand

= Création de Vias Structure HighSpeed (

Allegro Option HighSpeed):
Menu Route->Via Structure-> Create->High Speed, utilisable sur paire différentielles avec vias
de retour avec prise en charge de pistes, vias, Shapes statiques et Route Keepout.

m BackDrilling (Allegro)
Cette fonctionnalité est maintenant disponible dans Allegro Designer. Elle a été complétée par
['ajout d'option permettant maintenant de traiter ce principe dans le padstack.

Stat | Dnl | SecondaryDrl | Drilsymbol | Onll Offset | Desionlayers | maskLavers | options ¥ Backdrill
Select pad to change Diarmeter: 15000
Layer Mame Regular Pad Thermal Pad  Anti Pad
oG el St Tt o

PLAN_ALIMS Circle 1.3208  Flash AB46  Circle 1.6764
2 Circle 1.3208  Flash AB46  Circle 1.6764 Backdrill drill symbol
DEFAULT INTERNAL Circle 13208  Flash AB46  Circle 1.6764 Tyre of dl figure: | Cirdle
BOTTOM Circle 1.3208  Circle 1.6764  Circle 1.6764 e )

- ADJACENT LAYER Characters:
BACKDRILL START _ Mone Qe el Crril figure diameter: | 1.5000
BACKDRILL CLEARANCE - -

4

Le Cross-Section chart montre maintenant les usinages Backdrill
et les pastilles concernées portent les infos de backdrilling.
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Diamétre de backdrill

Séquence d'usinage
Start layer-End Layer-Must not cut layer

BackDrill Route Keepou

® Import PCB:

m Altium:
Il est désormais possible d'importer une carte Altium ou un schéma vers DE-HDL avec le menu:
=  PourAllegro PCB Editor:
File>Import-> CAD Translator—->Altium PCB/Altium Schematic to DE HDL.

=  Pour OrCAD PCB Editor:
Import-> Translators>Altium PCB
G Altium PCE Translator = =
Pour le PCB, il faut que le projet Altium ait été 4501 PebDoc il |
sauvé au format PCB Ascii File (*.PcbDoc)

[ Create Individual Symbal O efinitions

Tranzlate Wiewlog Close Help
Gor Altium Schem afic to HDL Translator — ©
) ] ] ) Alkium PPCE File: |
Pour le schéma, il faut que le projet Altium ait Oulput Project: |
été sauvé au format Advanced Schematic ascii [ ]Simple Symbel Graptic
(*.SchDoc). ] Simple Spmbol Fin
Tranglate Wiewlog Cloze Help
m Eagle:
Il est désormais possible d'importer une carte ou une bibliothéque d'empreintes Eagle avec le
menu:

= Pour Allegro PCB Editor:
File=> Import->CAD Translator->Eagle PCB or Library.

=  Pour OrCAD PCB Editor:
Import->Translators—> Eagle PCB or Library.

adjle an 1orary 1 rans ator =
G E PCB and Library Transl o IEN

brd/lbr file: ||

Translate Cloze Help

Prezz Translate and select Eagle board/library file to be translated!
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NOUVEAUTES

OrCAD PSpice V17.2 - 2016

Artedas France vous présente les nouveautés

de PSpice V17.2.

Nouveautés OrCAD PSpice V17.2 - 2016

Fonctions DelayT1() et DelayT() pour retarder vos
signaux.

Générateur du code pour compiler vos modéles
analogiques/digitaux décrits en C/C++,SystemC et
Verilog-A.

Version 64 bits.

Nouveaux modeles.



® Fonctions DelayT1() et DelayT()

Précédemment, il était possible de retarder un signal soit avec une ligne de transmission
(composant TLINE) soit avec une transformée de Laplace. Cette modélisation était tres
complexe et conduisait souvent a des problemes de convergence. Avec les nouvelles
fonctions DelayT1() et DelayT(), la modélisation d’un retard est facilite.

LN ouT

DelayT1(V(%IN),100u)

DelayT1(<signal>,<retard>) B AL

- #. 2w
UEIMy - w(OuT)

Si le retard varie en fonction du temps, il faut utiliser la fonction DelayT.

DelayT(<signal>,<retard>,<max du retard)

LN ouT

DelayT(V(%IN),V(controle),500u)

controle

A
’

3 u.n
WKL - U{DET)
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® Générateur de code pour compiler vos modeéles.

A partir du module PSpice Model Editor et du menu Model/DMI Template Code
Generator il est désormais possible de générer du code adapté a PSpice et a vos modeles
développés en C/C++ et SystemC.

Cette interface génére un projet Visual C++ dans lequel tous les fichiers sources
nécessaires a sa compilation y sont déclarés.

Dans Microsoft Visual Studio Express 2013, vous ouvrez le projet, vous y ajoutez votre
propre code et vous le compilez pour créer la librairie de lien dynamique (DLL) qui sera
appelée dans le modele PSpice.

L’interface crée automatiquement la librairie PSpice de simulation (*.lib) a partir de laquelle
la librairie Capture (*olb) sera générée.

Note : Microsoft Visual Studio Community 2013 doit impérativement étre installé pour
utiliser cette interface.

Use this dialog-box to auto-generate DMI template code for the following PSpice-DIMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS.
Recommended steps:

1. Testthe model code stand-alone by building an exe.

2. Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code.

3. Use the generated PSpice library (lib file) to create a schematic symbol The generated symbol can be placed
in the schematic for PSpice simulation.

Part Details

Part Name

Part Type

customPart

Digital C/C++

Digital C/C++

Interface Type

Port Entry

Analog

ISyste mC

VerilogA-ADMS

Parameters

Global Parameters

Device Parameters

=
-

Quiput

DLL File Name
Log File Name

DLL Location

customPartdll

customPartlog

CUsersistephan MAINALS\DMI | | Browse...

PSpice DMI Template Generator
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Pour le modéle Digital C/C++, deux types d’interfaces sont proposées : Combinatoire ou
Clockée.

Pour le modéle SystemC, l'interface est Clockée

|Combinat0rial Q

Combinatorial
Clocked

Les ports entrées/sorties sont directement éditables dans I'interface ou via un fichier CSV.

I Ports (7) CSV File I

Pour le modéle Analog, différents types sont proposes :

Generic Device :

Generic Device

Voltage-Confrolled Voltage Source
Function-DependentVoltage Source
Voltage-Confrolled Current Source

Function-Dependent Current Source

Generic Two-Node Device

Generic Three-Node Device

EXx : Source de courant commandée par une tension ou un composant a 3 broches.

Pour le modele Verilog-A, la DLL est automatiquement générée a partir du code. Le nom du
modele et du fichier doivent étre identiques.

Note : L'utilisation des DLLs générées requiert une licence PSpice Designer Plus, AMS
Simulator ou PSpice Adanced Analysis.

Nouveaux modeles.

e Power Integrations : Commutateurs de puissance TNY274-280.

e Vishay : Thermistances, Varistances, Capteurs de température. Séries : TFPT,
NTCS, NTCLE, VDRS, VDRH, MLV et PTS.

e Thyristor GTO : GTO (modele générique librairie Breakout).
e Optocoupleurs : PC457; PS8101 et HCPL_M453 (librairie OPT).
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® Rappel des fonctions importantes apparues dans les Hot-
Fix 16.6, intégrées dans la base de la V17.2.

Nouveau menu PSpice Component dans Capture :

Edit View Tools SI Analysis PSpice Accessori
o -8 aq
#} Pin Array...
ﬂEEII't... p pﬁﬁﬁl‘@l‘@

PSpice Component... PSpice Ground

Parameterized Part... Capacitor
1 Wire W Diode

Auto Wire »  Inductor
“L. Bus B Resistor
=& Junction ] Digital b
A Bus Entry E Discrete »
% Net Alias.. N | passives b
* Pawer.. F Source »
+ Ground... G =
[l Nff-Dane Cannector L
¥ Circuit Protection  * Modeling Application...
o| Diodes 4
- Passives »

[ Sources 4
o System Modules ’

Pour placer les composants passifs, les fonctions numériques, les semi-conducteurs et les
sources de tension ou de courant.

Pour rechercher les composants dans la base selon des mots clés ou selon leur fonction.
Menu Search...

Pour modéliser des composants Modeling Application... tels que des capacités, des
inductances avec leurs éléments parasites.

# | PSpice Maodeling Applicatio

Capacitance

Tolerance

Initial Condition (IC)

Parasitic Resistive Element————— —Parasitic Inductive Element
Series Resistance (ESR) 1m Series Inductance (ESL) 7

Parallel Resistor (RP) 200meg Self Resonant Freqt;gg(;,)' [60.1549
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Menu Search..

PSpice Part Search

B T

Zone édition recherche

IRésultats recherche

Nouveautés PSpice V17.2 - 2016

¥ Hide Categories View
Categories Library

» Eiogic

> mMagnetics

> mMemory

> i;lOptoElectronics

» [Epassive

> Epower Management

Search

bipolar 100v 5a

Xa)|

| Search All Categorie ¥ '

=]

PART NAME ‘ DESCRIPTION

"IN5338" "5A, 100V, NPN General Purpose Bipolar
Transistor (AA Enabled)”
"IN5339" "SA, 1_00V,I.NPN Power Bipolar
Transistor
" " "5A, 100V, PNP General Purpose Bipolar
2Ne192 Transistor (AA Enabled)"
- - "5A, 100V, PNP General Purpose Bipolar
206193 Transistor (AA Enabled)”
- " "SA, 100V, PNP Power Bipolar
ZN6193 Transistor"
"NE43T7" "25A, 100V, PNP General Purpose
Bipolar Transistor (AA Enabled)"
- o "25A, 100V, PNP Bipolar Transistor
2NE437/TO Device"
- - "1.5A, 100V, PNP Bipolar Power
25A51 Transistor (AA Enabled)”
" " "0.5A, 100V, NPN General Purpase
2504479 Bipolar Transistor”
"ISC4605" "0.5A, 100V, NPN E;eneral Purpose
Bipolar Transistor
" n "1.5A, 100V, NPN Bipolar Power
26510 Transistor (AA Enabled)”
"15A, 100V, PNP General Purpose
"BD912" Bipolar Switching Transistor (AA
Enabled)"
| "0.5A_ 100V, NPN Binalar Pawer
SYMBOL LIBRARY:




Pour créer intuitivement vos sources : Shift+R

Circuit Protection Modeling Application..
Diodes

Passives

Sources Independent Sources  Shift+R
System Modules PWL Sources

e e ] o Eoonento | 1 JEUY T pose | e

@®\oltage OCurrent

©1.2/50 uSec O 410 uSec ®4/20 uSec ©8/20 uSec 10350 uSec © 10/1000 uSec

Parameter Name Parameter Value

vP 1500
Delay 100u

_?élzﬂztsi?c Lightning Voltage Impulses Source (T1=4uy, ‘ Place ‘ ‘ Close ‘ ‘ Help |

C1Current P

Sighal Repettons

© PWL File | | ®None

@® PWL Paints

i Repeat Foraver

—Analog Value Time Pairs

N +
nepeal

i 1m m

— Advanice Options

Value Scaling Factor

Time Scaling Factor
AC
DC

[ Add Additional PWL points
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Filieres de Formations
Quel que soit votre niveau, trouvez la formation qui vous convient !

Dans le cadre de programmes de formation continue, Artedas, organisme agréé,
offre un suivi personnalisé a ses stagiaires.

Que vous souhaitiez une formation en nos locaux dans la région parisienne, une
formation dans I'ouest ou ailleurs en France, Artedas sait s'adapter a vos besoins.
Pour chaque type de formation, un support de cours en francais est distribué a nos
stagiaires, des supports de cours auxquels nous apportons un maximum de soins.

N° de déclaration d'activité de formation : 11 94 06989 94

(Artedas

1 bis avenue Foch
94100 Saint Maur - France
Tél: +33(0)170 91 67 20
E-mail: info@artedas.fr






