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Migration Guide

Migrating from CadSoft Eagle to OrCAD
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Overview

Choosing the right PCB design solution is never an easy task. No matter if you are a startup company
looking for tools to develop your first or next innovative electronic-centric product or a large enterprise
wanting a better solution to improve the productivity and efficiency of your design team and projects,
selecting a PCB solution can be a daunting task. No one wants to get 75% of the way through a design to
find out that the software you selected is not going to achieve what you need to accomplish.

There are many aspects you should consider when choosing your PCB Design solution, here are five that
many users of Eagle discussed with Cadence:

e Does the capabilities of the offering and its technology meet your design requirements?
e What's the cost of the solution offering? Does it fit within your budget?

e What's the support service like? Will you be able to get quick responses to your questions and access
online based tutorials, is there local help available?

e Can its technology and solution scale with your needs? As designs are getting more and more complex,
will the capabilities of the tool adjust accordingly? Can it offer breadth and depth?

e How many other companies in your industry are using this tool and what is their feedback?

With OrCAD®, you can be confident that you will have the right solution and technologies at an affordable
price to meet all of your design challenges today and tomorrow. Here are five of many reasons why:

e 30 years of innovation and leadership in the industry

Affordable price and flexible purchase models

Cutting-edge technologies

* Ecosystem empowered

Industry’s best customer support

Like many companies selecting OrCAD, you have existing or legacy designs you need to convert or translate
into OrCAD. The good news is that OrCAD is supplied with an integrated and proven Eagle design trans-
lator built in. This guide will walk you through the steps and process involved in getting your design IP into
the OrCAD format so you can start realizing the advantages of moving to OrCAD!

Watch how Eagle Schematic and PCB data are migrated to OrCAD.

Watch how Eagle footprint libraries are migrated to OrCAD.



https://www.orcad.com/resources/library/migrate-eagle-schematic-and-pcb-data-orcad
https://www.orcad.com/resources/library/migrate-eagle-footprint-libraries-orcad 
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Import Your Eagle Schematic Data to OrCAD Capture

STEP 1 - Preparation

Before you start translating your Eagle schematic data into OrCAD Capture, the schematic must be in .xml
format. If this is not the case, open the schematic in Eagle version 6.5 or later and save the schematic.

STEP 2 — Import the Eagle Schematic into OrCAD Capture

In OrCAD Capture, select “File » Import » Eagle Schematic Translator” to launch the Eagle to Capture
translator. Browse to the schematic file to be translated (.sch). Then specify an output directory for the
OrCAD project. Click on “Translate” button.

5}' Eagle PCE and Library Translator — >

.brd# lbr file: ||

Prezs Tranzlate and zelect E agle board/libram file to be translated!

Leave the OrCAD output path blank if the output files should be located in the same directory as the source
(.sch) file.
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Once finished, open the project and check the schematic for any issues. Ideally, for catching problems, you
should run the DRC tool (“Tools » Design Rules Check”) on the design.

Note: Make sure to check the log file shown after translation. It will show what happened during the
Schematic translation.
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(ELKO, Name=C5, Value=4 7uf 10V) (X=520, ¥=520) X=530, ¥=9%70
(CPCL, Name=C7, Value=N A) (X=080, v=080) X=080, ¥Y=822 WARNING : Not on Grid

Replaced part name/Value

ELKO: Partvalue '4,7uf/10V' replaced by '4_7uf_10V'
R: Partvalue '0207/10' replaced by '0207_10"

R: Partvalue '0207/10' replaced by '0207_10"

R: Partvalue '0207/10' replaced by '0207_10'

R: Partvalue '0207/10' replaced by '0207_10"

ELEO: Partvalue '2200uF/35V' replaced by '2200ufF_35vV'
ELKC: Partvalue '4,7uf/35V' replaced by '4_Tuf 35v'
ELEC: Partvalue '4,7uf/10V' replaced by '4_7uf 10V'
CPOL: Partvalue 'N/R' replaced by 'N_R'

et alias replacements
'IOES' replaced by ' OE5' - net alias position : Eagle coord : 1190, 810, Capture coord : 1210, 280
''OE5' replaced by ' OE5' - net alias position : Eagle coord : 140, 810, Capture coord : 160, 280

The translation is done with connectivity in mind. This ensures a very high probability for design integrity
and synchronization with the translated PCB design without any changes in connectivity, number of parts, etc.

Before creating a netlist for PCB synchronization, translate the Eagle PCB data to OrCAD PCB Editor. Do not
close the project in OrCAD Capture!

Import Your Eagle PCB Data to OrCAD PCB Editor

STEP 1 - Preparation

Before you start translating your Eagle PCB design data into OrCAD PCB Editor, the PCB design data must
be in .xml format. If this is not the case, open the pcb in Eagle version 6.5 or later and save the board file
(.brd).

STEP 2 — Import the Eagle PCB Design into OrCAD PCB Editor

Start OrCAD PCB Editor.

Select “Import » Translators » Eagle PCB or Library”.

File [Import | Setup Display Outline Add Edit Place Route Shap
B Netlist... B @ }? @
MCAD 3
Color/Board Parameters... = @ H
Techfile...
Clipboard...
Placement...
=E Translators N PADS... Q Eagle PCE and Library Translator — *
- More » gEADs
o PADS Library. b/ lbrfile: |
m Altium PCB...
Fl_r Altium Schematic to DE HDL... Cloze Help
: Eagle PCEB or Library Press Translate and select Eagle boardflibrany file to be translated!

Click “Translate”.

Browse to the Eagle PCB file and select “Open” and the translation starts.
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Seqi: || import - & F B -
T= MNavn B ZEndringsdato Type Starr
e ] new_blank.brd 06-04-201611:31  BRD-fil
Seneste steder (o] Cample.brd 06-04-201610:59  BRD-fil
Skrivebord
Jﬁi_.::]
Biblioteker
i ¥
=
Computer
< 1 | 3
@ Filnavn: sample brd - Abn
MNetwasrk
Filtype: Ezgle board(" brd) v] Annuller

The command window shows the translation progress.

Note: In some cases, especially for larger boards, it might seem like PCB Editor has stopped working. Do
not close it as tests on large boards have shown translation times taking over five minutes, although
this is unusual.

Note: Make sure to check the log file shown after translation. It will show what happened during the
PCB translation. The most important part is at the bottom where statistics will compare the net and
component count in the Eagle board with the data in the translated board.

Translation statistics
Components: Eagle 30 -> 30 on translated board
Nets: Eagle 68 -> 68 on translated board
rWarninga
Duplicate footprint names found!
Fix issue backannctating footprint names from PCB Editor to OrCAD Capture.
Backannotation file created "sample_backannc.awp™ in F:/import/
In OrCAD Capture do the following
1. Go to Project Manager
2. Felect "Tools -» Back Rnnotate”
3. Select "Layout" tab. Otherwise never use this tab of the dizleg for PCB Editer.
4. Browse and select the backannotation file menticned above
5. Click ™OK" to update the schematic design in OrCAD Capture with correct footprint names

After the above steps are performed a netlist can be created in OrCAD Capture and imported toe PCB Editor.

Translation ended at: "Rpr 06 11:32:02 2016"

The log can show two important warnings. Only one of them is present in this board.
“Nets with no pins found” (Not shown in this example.)

The statistics above this warning show the net count in both the original Eagle board and the translated
PCB Editor board file.

If there is a mismatch, it is typically caused by “free” vias placed in Eagle. They are automatically assigned
net names. This type of via will not have any net connection to the schematic and the net attachment

is removed during netlist import. The same situation can occur if two or more free vias are placed and
connected with a wire (cline) in Eagle but without being connected to a pin.

The translator will check if a net has any pin attachment and if not, warn that this is the case. The log file
will show all the nets without any pin attachment and also report what the net count should be after netlist
import.
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“Duplicate footprint names found!”

This warning means that a backannotation process is needed to get the footprints’ names aligned between
the translated board and the translated schematic design. All steps involved are listed in the log and

the necessary backannotation (.swp) file is generated for immediate use in OrCAD Capture. If duplicate
footprint names are found, only the first instance will use the original footprint name, and the others will
get the footprint library name added. In the example swap file for backannotation, C4 uses a “E2_5-5"
footprint, as does C7 but from a library named RESISTOR, and the footprint is renamed to libraryname_
footprintname.

"Cc2" "C5B2 SA™

"C4n "E2 5-5"

"CS" "E2 55" \
"M "TO220H"

"U2" "TO220H"
"RS" "0207_10"
"R4" "0207_10"
"R2" "0207_10"
"R1" "0207_10"
"D1" "D041Z10"
"R3" "0207_10 1"
"JP1" "1X02"
"C1n "E35-16"
"CE" "E2 5-5"
"c7" "RESISTOR E2 5-5"

library name added
before footprint name

If there is no duplicate footprint warning in the log file, the back annotation process can be skipped. In
that case, move ahead to “Synchronizing OrCAD Capture and PCB Editor Design”.

STEP 3 — Backannotating Footprint Names from PCB Editor to OrCAD Capture

This step is only necessary if the bottom part of the log file after Eagle PCB to OrCAD PCB Editor states that
there are “Duplicate footprint names found”. If not, move ahead to “Synchronizing OrCAD Capture and
PCB Editor Design”

Go back to OrCAD Capture without closing OrCAD PCB Editor.
Select “Tools » Back Annotate” in OrCAD Capture.
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OrCAD Capture CIS - [f - (SCHEMATICI : PAGE1]]
E File Design Edit Wiew Place SIAnalysis

LEEHS %

Access

Update Properties...

= . Test Bench L
% &g % Q e Part Manager *

=% Design Rules Check..,

FCE [Z] Create Netlist...

3 Fie m Create Differential Pair...
ierarchy =

=0 Design Resources b Cross Reference..

=] - \import\sampl

= mooven onrrd [ Bill nf bdateriale

InterSheet References...

Select the “Layout” tab. Select “Browse” and select the .swp file created by the Eagle PCB translator.

Note: This file is only created if necessary, so if there are no .swp file in the same directory as the translated
board file, you can skip this part.

N — |
" =1

Scope

@ Process entire design

() Process selection

Mode
() Update Occumences

@) Update Instances (Prefemred)

oK || Aonuler ][ Hzb

Click "Ok" to update the OrCAD Capture project with the footprint names in the board file. Check the
Capture session log “Window » 1. Session Log” to see that all parts are updated.

Now the design is ready for synchronization.
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Synchronizing OrCAD Capture and PCB Editor Design

STEP 1 - Creating a Netlist in OrCAD Capture

Select “Tools » Create Netlist”.

oo I =

PCB Editor |EDIF200 [ INF | Layout | PSpice | SPICE | Verlog | VHDL | Other |

PCE Footprint
Combined property string:
PCE Footprint

Create PCE Editar Netlist

Optionz

Metlist Files Directony: allegra E]
[ Wiew Output

[ Create or Update PCE E ditor Eoard [Metrev]
Optiohs

Input Board File: |

Output Board File: |allegro\SAM PLE .brd

[ &llow Etch Remaval During ECO [ &llow User Defined Property
[T lgnore Fixed Property
Flace Changed Components: (@) Always If Same Mever

Board Launching Option
(@ Open Board in &llegro PCE Editar Open Board in APD
Open Board in OrCAD PCE E ditor

) [Thiz option waill nat transfer any
Do not open board file high-spesd properties b the board)

Open Board in Cadence SiP

[ ok || Aondler | [ Hae

Click “Ok" to create the netlist and accept saving the project and creating an allegro subdirectory.

=% QUESTIOM({ORCAP-32013): Directory "FAIMPORT\allegro” specified as
MNetlist directory does not exist.
Do you want to create it? |

Note: The allegro subdirectory with the netlist is created in the directory where the OrCAD Capture
design is located.
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STEP 2 — Importing the Netlist in OrCAD PCB Editor
Select “Import » Netlist”.
7 reor oo . —

Branding: Design_Entry_CIS

Import
Cadence

Impoit logic type Flace changed component
() Design entry HOL @) Always | Wiswlog...

@ Design entry CIS (Capture () MNever
e

() It zame symbol

Unconditional Cancel

HOL Constraint Manager Enabled Flow options Help

= — - (@) Impart changes anly Ovenarite current constraints
g QrCAD PCE Designer Professional: sample_allegro.brd Project: E! ::E; — o
- - || Show constraint difference repart

@ o ﬂ } g [ Allow stch removal duing ECO
[ Igrore FIXED property
Color/Board Parameters... m g H E [ Create user-defined properties |M
X [ Create PCE %ML from input data
Techfile...
Clipboard...
Placement... I Import directory:  |F:Aimport/allegra E] I
Translators 3

In the Import Logic window, make sure that the Import directory points to the allegro subdirectory with the
netlist. This directory was created in the previous step.

Click “Import Cadence” to import the netlist.

This process should complete successfully.

10
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STEP 3 — Check Design Status

Select “Check » Design Status” and, if necessary, click “Update to Smooth” to update the dynamic
copper shapes.

Statuz

Symbols and nets

E Unplaced symbaols; 0430 0%

E Unrouted nets; 0/68 0%

[E Unroued connections; 07206 0%
Shapes

[E 1solated shapes: i

] IInassigned shapes: i

[E Out of date shapes: 041 | Update to Smooth |
Dynamic fill: @ Smooth (D) Rough () Dizabled

DRCz and Backdiills

DRC emors: Up To Date 4 |dpdate DRC
1]

B Shorting erors:
¢ Ondine DRC

[ waived DRC erors: i
B waived shorting errars; i
[ Out of date backdiills | Update Backdril |
Statistics
Last zaved by Ole

E diting time: 7 minutes

STEP 4 — Check Physical and Spacing DRC Constraints

Start the Constraint Manager ﬂ Check and verify the physical and spacing DRC rules.
Update the online DRC using the toolbar icon% .

STEP 5 — Change to Preferred Colors

Changing the colors to suit your preferences is easy. Select the color and visibility toolbar icon and
change your color preferences accordingly.

11
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Importing Eagle PCB Libraries into OrCAD PCB Editor

STEP 1 - Preparation

Before you start translating your Eagle PCB footprint library into OrCAD PCB Editor, the library data must be
in .xml format. If this is not the case, open the library in Eagle version 6.5 or later and save it again (.lbr).

STEP 2 — Import the Eagle PCB Footprint Library into OrCAD PCB Editor

All the footprints in the library are imported to a board file. After the translation, they can be exported as
individual footprints and padstacks.

Start OrCAD PCB Editor.

Select “Import » Translators » Eagle PCB or Library”.

ﬁ OrCAD PCE Designer Standard: import_board.brd Project: Ci.../eagleZorcad/atla
File | Import| Setup  Display Outline  Add  Edit  Place Route  Shape  C

§|_L| [Hetlist.., @ }? H G
d MCAD » J
E Color/Board Pararneters.., ™| @ IE‘
----- Techfile...

Clipboard...
e Placement...
=m Translators EADS.. E}' Eagle PCB and Library Translator — >

kdore 4 PCAD..

T PADS Library..
.brd/ lbr file: ||

Altiurn PCE..,

Press Translate and select Eagle board/library file to be translated!

..... Eagle PCE or Librany

Click “Translate” and make sure to change the filetype to “Eagle library (*.lbr)".

Browse to the Eagle library file (.Ibr) and select “Open” and the translation starts.

Segi: . library - O 2 = M-
T= Mavn - Zndringsdato Type Sterrelse
e [[] eagle-ltspice.lbr 07-01-201306:04  LBR-il 10
Seneste steder \
Skrivebord
I=H
Biblioteker
L ¥}
Computer
eu; o 1 | 3
™ Filnavn eagletspice lbr -
Netveerk
IFihwe: | Eagle library(* b v]l [ Aonuter |
Hjzlp

The command window shows the translation progress.

Note: In some cases, especially for larger libraries, it might seem like PCB Editor has stopped working. Do
not close PCB Editor but leave it running for a while.

Note: After the translation is finished, a log file will show what was done during translation.

12
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4 Creating fectprint: RO205

Unknown ckject: "<b>RESISTOR</b><p>"

SMD: pin 1 at (-0.55 0.0) with pad rl30_150ml50pl30

SMD: pin 2 at (0.95 0.0) with pad rl30_150ml50pl30

Rectangle: Create ((0.4064 -0.6985) (1.0564 0.7015)) on PACKRAGE GECMETRY/ASSEMBLY TCOP

Rectangle: Create ((-1.0668 -0.8%85) (-0.4168 0.7015)) on FRCEAGE GEOMETRY/ASSEMBLY TOF

Rectangle: Create ((-0.195%3 -0.5001) {0.1953 0.5001)) on PACKAGE GECMETRY/GLUE_TOF

Text: NAME created at (-0.635000 1.270000) on REF DES/SILESCREEN_TCP

Text: VALUE created at (-0.835000 -2.540000) on CCMPCNENT VALUE/ASSEMBLY TOP

Wire: created {({-0.41 0.835)) -> {{0.41 0.835)) with width 0.152400 on PACKAGE GECMETRY/ASSEMBLY_ TOP
Wire: created ({-0.41 -0.835)) -> {(0.41 -0.835)) with width 0.152400 on PACERGE GECMETRY/ASSEMBLY TCP
Polygon shape: created on PACEAGE GECMEIRY/PLACE BCUND_TOP

Create footprint as package symbol: ROB05

[ A N

The “Unknown object” at the start of the file is a description text that is not translated for the footprint.
The rest of the file lists the elements created for the footprint. The padstack names are translated so that
they are ipc-like.

All the footprints are placed at the origin of the board and can be moved using standard PCB Editor place/
move functions.

Right click and select “Placement Edit".

Quick Utilities k

Application Mode  »

Super filter »
Customize r
Selection set 4 Signal Integrity

Shape Edit

VALUE

Mone

Use “Export » More » Libraries” to export to symbol and padstack files. It is a good idea to specify a
subdirectory for the files created. The data are exported to a subdirectory named symbols in the same

13




Migrating from CadSoft Eagle to OrCAD

|

Select elements:
techanical zymbols
Package symbols Cloze

All
Format symbolz
Shape and flazh symbaolz

Device files

Fadstacks Help

o library dependencies
[¥] Ma library d denci

Export

Ewport to directon:

p ¢

|$_I,Iml:u:|Is

directory as the translated library.

The OrCAD PCB Editor library footprints and padstacks are then created.

wor . ==

Segi: || symbols - & F rE-

Ti== Mavn £Endringsdato
el #0204 7.dra 01-04-201611:31
Seneste steder 5 1207 10.dra 01-04-2016 11:31
[#] c0201.dra 01-04-2016 11:31
[ ] c0402.dra 01-04-201611:31
4] c0504.dra 01-04-2016 11:31

- ) c0B803.dra Type: DRA-fil 1:31
= |P#| c0805.dra Starrelse: 48,6 KB 131
Biblicteker 2] c1005.dra £Endringsdate: 01-04-2016 11:31 1,31

) ) c1206.dra 01-04-2016 11:31
ﬂﬂa-&.,‘!' % c1210.dra 01-04-201611:31
] c1310.dra 01-04-201611:31

Computer

O

Filnavn: c0402 dra

Filtype: Symbal Drawing (*.dra)

Change Directory

If you have any questions about the migration or in general about OrCAD, please do not hesitate to contact
your local Cadence Channel Partner at http://orcad.com/about/contact-us.
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