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Modélisation d’un noyau magnétique avec PSpice

Noyau magnétique

Cette note d’application aborde les sujets suivants :

e Comment modéliser un noyau magnétique dans PSpice.
e Simuler et vérifier les paramétres clés du modéle dans un circuit réel d’application.

Un noyau magnétique permet de faciliter et de canaliser un flux entre deux ou plusieurs
éléments magnétiques. Les noyaux sont réalisés en matériau ferromagnétique (fer) ou en
matériau ferromagnétique composé (ferrite)

PSpice propose deux types de modeles pour les simuler :

e Modele Jiles-Atherton, connu comme le modele Level 2 dans PSpice
» Ce modele supporte des valeurs de couplage <1
» Les parameétres du modele ne peuvent pas étre directement déduits de la
datasheet. Ils ont besoin d’étre extraits en utilisant I'outil PSpice Model Editor ou
un outil équivalent.

e Modeéle Tbrizi, connu comme le modéle Level 3
» Ce modele supporte seulement des couplages idéaux
» Les parametres du modele peuvent étre directement déduits de la datasheet. Ces
modeles pour un nouveau matériau peuvent étre développés tres rapidement

Dans ce document, nous aborderons le développement d’un modéle Jiles-Atherton.

Parametres AU NOYAU ..oc.ueccveecieeiieeceecieecee et esteeste e teesteesteessseessaeesseesseesssessseessseessessssessseesnsans 3
Comment modéliser un NOYau MAGNELIQUE 7 ..c..eeuirierierierieneerieete e ete e ee s e sreseesaeas 4
1. Modélisation du matériau PCA4.........ccoviiieiienienienieneneeeetetetesee ettt 5
2. Modélisation du noyau PC44PQ32/30Z-12 ...cccccvveecuerienerirenienieeieneenesssesnenseeseennns 6
Circuits de test pour [e NOYau MAagNELIQUE ......ooueiviiriirieieeieeteeetesee ettt 8
1. Circuit de test pour vérifier [a courbe B-H du NOYaU. ....cccceccvverveecieeniecreenieeieennens 8

2. Circuit de test pour mesurer 'inductance d’'une bobine réalisée a partir du noyau
magnétique avec un nombre de spires et un entrefer donné. ........cccoevevereniiniiniieninnnn. 9

01/07/2024 www.artedas.fr 2



Modélisation d’un noyau magnétique avec PSpice

Parametres du noyau

Les parameétres du modele Level 2 dans PSpice peuvent étre divisés en deux catégories
suivantes:

e Les parametres définissant les caractéristiques du matériau magnétique. Ex: le
champ magnétique maximal.

e Les paramétres définissant les caractéristiques physiques du noyau. Ex: la surface
de la coupe transversale du circuit magnétique.

Les paramétres définissant les caractéristiques du matériau ont besoin d’étre extraits depuis
leur courbe de caractéristique. Ex : courbe B-H.

Les paramétres définissant les caractéristiques physiques peuvent étre directement
obtenus depuis la datasheet. Ces parametres sont :

e AREA en cm2 est la surface effective de la coupe transversale du noyau.
e PATH en cm est la longueur effective du chemin magnétique.
e GAPencmestlalongueur de l’entrefer.

Ces paramétres peuvent étre obtenus directement depuis la datasheet comme ci-dessous.

S&TDK
PQ Series PQ32/30 Cores
Parameter
i o | E— " C1 om0,
o _i_‘_li Effective magnetic path length ie mm_ 74.6 PATH
s T8 } s Effective cross-sectional area Ae mmé 161 ARFA
25 i e ,»=[ — |2a 9 f coTe e pr——
- =] 0 E S Cross-sectional center pole area mme 142
. A ¢ — |axld Minimum cross center pole area ACp min. mn?_ 137
=| ) = Cross-sectional winding area of core Acw mme_ 149.6
B ol o e Wolght (approx) . &
. [ -
i . J 1
| 220:05 | |__213:03
30.3520.25
Dimensions in mm
Core loss (W) al 100°C Calcuiated output power
R o Al-vaiue (THIF) T00KHzZ, 200mT {forward converter mode)
PC44PQ32/30Z-12 5140:25% (1kHz, 0.5mA)” 3.02 max. TW (100kHZ)

6790 min. (100kHz, 200mT)

* Coil: 0.4 2UEW 100Ts
AL-value vs. Alr gap length for
PC44PQ32/30 core (Typical)

10°

Center pole gap

N

-1 Spacer gap* X

102

AL-valueinHNE)

0.1 1
Air gap lengthimm)
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Modélisation d’un noyau magnétique avec PSpice

Comment modéliser un noyau
magnétique ?

Essayons de construire un modele pour le noyau PC44PQ32/30Z-12 de TDK. Voici une vue
combinée de la datasheet du noyau et celle de son matériau le PC44.

&TDK

PQ Series PQ32/30 Cores

Av-value vs. Air gap length for

Parameter PC44PQ32/30 core (Typical)
R I ------- . re facto Cl Ot 0464
<L i |
P RVAR 18 ol : : 105
2 ) E 2 Cro! center pole area Acp mme_ 142
. , 2 BN Minimum cross-sectional center pole area ACp min. mm? 137 — Center pole gap
S m ] = Cro: winding area of core Acw mm? 1496 % h X
. P ! ! Weight (approx) g & I ffpacer gap
LT T N
| 2005 | [ orases | ‘g: 02
30.35+0.25
Dimensions in mm
Part No. AL-value (NH/N?) mf&?ﬁaﬁ 100°C fﬁjmmefo‘r’”ﬂg(m;) CZ R 10
, forward ir gap length(mm;
PCA44PQ32130Z:12 :;;%fﬁs:ﬂﬁﬁmﬁ 392 max. 331W (100kH?)
* Coil: 00.4 2UEW 100Ts
MATERIAL CHARACTERISTICS
Initial permeability ui 25°C 2400+25% I
- et et
[c°1 m‘mz‘g““'n"d“m" Pov  kWm®  60°C 400
100°C 300
Saturation magnetic flux density Bs T 25°C 510
[1000A/m)] 100°C 390
; 25°C 110
Remanent flux density Br mT 300°C &0
Curie temperature Te °C min. 215
Density do kg/m? 48103
Material: PC44
2|5°C
500 ;
.l 60°C
foe |
" .
400 A 100°C
= P 120°C
E f | —
m ]
= 300
"]
c
5]
o°
5 200
[
100
0
0 800 1600
Magnetic field H(A/m)

01/07/2024

www.artedas.fr



Modélisation d’un noyau magnétique avec PSpice

Pour créer un modele PSpice, vous avez besoin d’extraire les paramétres du modele depuis
le matériau magnétique, qui est ici le PC44.

e Llancez le programme PSpice Model Editor 20xx depuis le groupe de
programmes Cadence PCB Utilities 20xx.

e Menu File > New. Puis Model > New

e Spécifiez le nom du modele : PC44PQ32/30Z. Sélectionnez 'option « Use Device
Characteristic Curves » et choisissez Magnetic Core depuis la liste From Model.
Puis OK.

0K

~ ~ Cancel
Use Device Charactenstic Curves
Help

Use Templates

From Model Diode

MOSFET

Vous devriez obtenir une fenétre avec une courbe d’hystérésis (courbe B-H).

Le modele PC44PQ32/30Z-12 est basé sur le matériau PC44, donc premiérement nous
modéliserons ce matériau puis le noyau basé sur ce matériau.

1. Modélisation du matériau PC44

PSpice et PSpice Model Editor demandent que les parametres soient édités dans le systeme
CGS. Les formules suivantes vous permettront de convertir les valeurs du systeme Sl vers le
systeme CGS.

1 mT = 10 Gauss
1A/m = 0.01257 Oersted

e Editez quelques points de données depuis la portion de la courbe B-H ou le champ B
varie de 0 a Bsat.

e Renseignezlavaleur de la perméabilité initiale.

e Modifiez les échelles (Plot > Axis Settings) pour visualiser 'ensemble des points
édités comme ci-dessous :
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Modélisation d’un noyau magnétique avec PSpice

OK

Scale

T Cancel

Help

Scale

Linear

to B.OK

e Puis pour extraire les parametres modélisant la courbe B-H, menu Tools > Extract
Parameters.

Hysteresis Curve

+ B (Gauss) (27°C)
] H (Oersteds)

Parameters

Parameter Name Value Minimum | Maximum Default Active Fixed
LEVEL 2 1 2 2

I3

L] d<i<i<f<i 1 |
EEEEEEEEQ

e Ci-dessous, la courbe B-H modélisée avec les points et la valeur de pi édités.

2. Modélisation du noyau PC44PQ32/30Z-12

Les parametres physiques du noyau doivent ensuite étre ajouter au modele du matériau
PC44 précédemment développé. Pour ce faire, il nous faut éditer les valeurs des paramétres
AREA, PATH et GAP extraits de la datasheet dans le tableau des parametres de ’éditeur de
modeles.

L'entrefer peut étre obtenu depuis le graphe AL fonction du GAP de la datasheet. Mais étant
donné que le noyau PC44PQ32/30Z peut-étre choisi sans entrefer, on indiquera GAP=0 dans
le tableau. Ce sera sa valeur par défaut.
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Modélisation d’un noyau magnétique avec PSpice

La fenétre des parameétres dans PSpice Model Editor est donc définie comme ci-dessous :

Parameter Name Value Minimum | Maximum Default Active Fixed

LEVEL 2

Apres sauvegarde de la librairie, le modeéle est prét pour la simulation.

NOTE : Pour utiliser ce modeéle dans un schéma, nous avons besoin de créer un symbole
pour ce noyau. Ceci peut étre fait en utilisant un assistant. Pour cela, accédez au menu File
> Model Import Wizard comme montré dans l'image ci-dessous et cliquez sur Suivant.

Model Import Wizard : Specify Library X

Mode! Import Wizard automatically associates symbals far allthe P Spice modsls it recagnizes.
t facilitates the user to

- assaciate symbols for the PSpice models that could not be recognized automatically
-Update existing symbols for the PSpice models

Enter Input Model Library -
| \Dossiers_intemes"Appiication Nete\MODELISATION_NOYAU_MAGNETIQUE| Browse

Enter Destination Symbol Library -
[C:\Dossiers_intemes\Application Note\MODELISATION_NOYAU_MAGNETIQUE]| Browse

Précédent Arler Hide

Model Import Wizard : Associate/Replace Symbol X

I Destination Symbol Library : C:\Dossiers_intemes\Appiication Note\MODELISATION_NOYAU_MAGNET
o -

You can do either of the following
(1) associate symbol for models without symbol, or (2} replace existing symbol for models

Models with symbol Models without symbol Symbol : PC44PQ32/30Z-12

Model Name Symbol Name A
PC42PQ32/30Z-12 PC44PQI2/30Z-12

K]

COUPLING=

Replace Symbaol

View Madel < Précédent Arnuler fide

Cliquez Terminer.

Le fichier OLB est sauvegardé dans le méme répertoire que la librairie de simulation (*.LIB)
et pourra étre utiliser dans Capture pour placer le composant.
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Modélisation d’un noyau magnétique avec PSpice

Circuits de test pour le noyau magnétique

1. Circuit de test pour vérifier la courbe B-H du noyau

K] K1
PC44PQ32/30Z-12
COUPLING=1

L1=11

VOFF =0 (~0N
VAMPL =450 ‘. —/
FREQ = 100k

AC=

NOTE : La librairie du modéle de simulation du noyau doit étre ajoutée aux fichiers de
configuration du profil de simulation.

La valeur de VAMPL est choisie afin de faire saturer le noyau.

Ala suite d’une analyse temporelle, nous obtenons le résultat suivant.

Le signal B(K) est ajouté via le menu Trace > Add et le signal H(K) est placé sur ’axe des X a
l’aide de bouton Axis Variable de la fenétre de configuration des axes (menu Plot > Axis

Settings)

Cette courbe correspond au cycle d’hystérésis du matériau du noyau, c’est-a-dire ici le PC44
avec le champ magnétique B en Gauss et le champ inductif H en Oersted. Elle est tres
similaire a celle disponible dans la datasheet du matériau.
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Modélisation d’un noyau magnétique avec PSpice

2. Circuit de test pour mesurer 'inductance d’une bobine réalisée a partir
du noyau magnétique avec un nombre de spires et un entrefer donné

VAMPL = 10
FREQ = 100k
AC=

Dans le circuit ci-dessus, la valeur de l'inductance représente le nombre de spires de
’enroulement réalisé autour du noyau magnétique. La valeur « Lbob » de la propriété L1 du
symbole K1 permet de coupler 'inductance Lbob au noyau.

La valeur de VAMPL est ici choisie afin de ne pas saturer le noyau.

Théoriquement, l'inductance d’une bobine est déduite de la formule suivante :
L(nH) = N? « AL(nH)

Avec N le nombre de spires et AL inductance spécifique du noyau.

Si on souhaite réaliser une bobine de 40pH avec 10 spires, AL doit étre égale a 400nH.

Dans la datasheet, AL est donnée en fonction de I’entrefer (GAP). Pour obtenir une valeur de
400nH, ’'entrefer doit mesurer 0.047cm.

Apres avoir défini la valeur de GAP dans le modéle de simulation et lancé une simulation
temporelle, il est possible d’extraire la valeur de 'inductance a partir de la relation suivante :

v 1

L = *
I(L) 2*m*F

Avec V(L) tension efficace aux bornes de la bobine et I(L) courant efficace parcourant la
bobine. Ces grandeurs seront extraites a la fin de la simulation a l’aide de la fonction mesure
YatLastX.
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Modélisation d’un noyau magnétique avec PSpice

Le résultat est le suivant :

Evaluate Measurement Value

[ | = YatLast{rms (W (Lbob: 1))} YatLast{rms(I{Lbob)) N(2=pi*100k) ! 39.89120u

On peut calculer le pourcentage d’erreur : %1891“ =0.27%

Ceci valide parfaitement le modéle de simulation du noyau développé avec PSpice Model
Editor.

Références:

Cette note d’application fait référence a un document Cadence intitulé « Modeling Magnetic
Core with PSpice ».

Le logiciel utilisé est PSpice Designer v23.1.
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